Downloads:

Requirements:

.Net Framework 4.5 , Powershell 4 (part of Windows 8.1 and Windows 10)
Note: Software is mainly tested on Windows10 x64, but feel free to create and upload x86 versions.

Latest (5) repository changes:

Feel free to create and upload your favourite tool if you miss it in the Repository...

Skype 7.33.1042/20/2017
AIMP v4.13.1887, 19.02.20172/19/2017
MKVToolNix 9.9.02/19/2017
ImageMagick 7.0.42/18/2017
SmartFTP Client 8.0.2299.02/18/2017